Overview

Stellar Repair for SQLite software is an easy to use application designed to repair corrupt or damaged SQLite database (DB / SQLITE) files in a safe and non-destructive manner. It uses powerful algorithms to perform thorough scan of DB & SQLITE file so as to repair as much data as possible. The software never deletes or modifies original data and even heavily damaged files can be optimally repaired.

SQLite is an in-process library that implements a self-contained, server less, zero-configuration, transactional SQL database engine. It is the one database, which is zero-configured, that means like other database you do not need to configure it in your system. SQLite database files (DB / SQLITE) can get damaged or corrupted due to a number of reasons such as virus attack, unexpected system shutdown, media read error and so on.

Key Features

- Support for SQLite3.
- Searches DB & SQLITE files in the computer.
- Displays preview of repairable database objects.
- Allows finding of object name in tree view.
- Repairing of Tables, Views and Triggers.
- Option to repair deleted records.
- Support for recreation of a new database having all the repaired database items.
- Support for large DB / SQLITE files for SQLite3.
- Support for separate log report after repairing database.
- Support for fast scanning algorithms.
- Repairing of Primary Keys and Unique Keys.
- Repairing of Predefined defaults and default values.
Installation Procedure

Before beginning the installation procedure, make sure that the computer meets the minimum system requirements.

Minimum System Requirements:

Operating system: Windows 10 / 8.1 / 8 / 7

Hard Disk: At least 250 MB of free disk space

RAM: 2 GB minimum (4 GB recommended)

To install the software, follow the steps:

1. Double-click **StellarRepairforSQLite.exe**. Setup dialog box is displayed.

2. Click **Next** to continue. License Agreement dialog box is displayed.

3. Select I accept the Agreement option. Click Next.

4. Specify the location where the installation files are to be stored. Click Next.

5. Select the folder where the files are to be stored. A default folder is suggested in the box. Click Browse to select a different location. Click Next.

6. In the Select Additional Tasks dialog box, select check boxes as per your choice. Click Next.

7. Review your selections. Click Back if you want to make any change. Click Install to start installation. The Installing window shows the installation process.

8. After completion of the process, Completing the Stellar Repair for SQLite Setup Wizard window opens. Click Finish.

**Note:** Clear Launch Stellar Repair for SQLite check box to prevent the software from launching automatically.
Launching the Software

To launch Stellar Repair for SQLite in Windows 10:

- Click Start icon -> All apps -> Stellar Repair for SQLite -> Stellar Repair for SQLite Or,
- Double click Stellar Repair for SQLite icon on the desktop. Or,
- Click Stellar Repair for SQLite tile on the home screen.

To launch Stellar Repair for SQLite in Windows 8.1 / 8:

- Click Stellar Repair for SQLite tile on the home screen. Or,
- Double click Stellar Repair for SQLite icon on the desktop.

To start the application, do one of the following in Windows 7 / Vista / XP:

- Click Start -> All Programs -> Stellar Repair for SQLite -> Stellar Repair for SQLite. Or,
- Double click the Stellar Repair for SQLite icon on the desktop. Or,
- Click Stellar Repair for SQLite icon in Quick launch.
User Interface

**Stellar Repair for SQLite** software has a very easy to use Graphical User Interface. The user interface contains features required for complete repairing of corrupt SQLite database (DB & SQLITE) files.

After launching the program, you will see the main user interface as shown below:

![User Interface](image)

The user interface contains menus and buttons that lets you access various features of the software with ease.
Menus

File Menu

Select Database
Use this option to select the corrupt SQLite database for repairing.

Save
Use this option to save the repaired SQLite database.

Stop
Use this option to stop the repairing process.

Exit
Use this option to quit Stellar Repair for SQLite.

View
Use this option to show or hide the Status Bar and Log Window.

Tools Menu

Save Log
Use this option to save the log report.

Clear Log
Use this option to clear the log report.

Register
Use this option to register the software after purchasing.

Update
Use this option to update the software.
Help Menu

Purchase
Use this option to buy Stellar Repair for SQLite.

Submit Enquiry
Use this option to submit enquiry to stellarinfo.com

Knowledgebase
Use this option to visit the Knowledgebase articles of stellarinfo.com

Help
Use this option to open the help manual for the software.

About
Use this option to read more information about the software.
Buttons

Click this button to open Select SQLite database dialog box.

Click this button to save the repaired SQLite database.

Click this button to stop the repairing process.

Click this button to quit Stellar Repair for SQLite.

Click this button to save the log report, which contains the details of the repairing process.

Click this button to clear the log report.

Click this button to register the software after purchasing.

Click this button to update your software. Use this option to check for both, major and minor versions of the software.

Click this button to purchase the software.

Click this button to submit an enquiry to stellarinfo.com.
Click this button to visit the Knowledgebase articles of stellarinfo.com.

Click this button to open the help manual for Stellar Repair for SQLite.

Click this button to read more information about the software.
Ordering the Software

Click http://www.stellarinfo.com/sqlite-repair.php to know more about Stellar Repair for SQLite.

To purchase the software online, please visit http://www.stellarinfo.com/database-recovery/sqlite-repair/buy-now.php

Alternatively, click on Purchase icon in Help Menu on Menu Bar to purchase the software online.

Select either of the methods given above to purchase the software.

Once the order is confirmed, a serial number will be sent to you through e-mail, which would be required to activate the software.
Registering the Software

The demo version is just for evaluation purpose and must be eventually activated to use the full functionality of the software. The software can be activated using the Activation Key which you will receive via email after purchasing the software.

To activate the software:
1. Run demo version of Stellar Repair for SQLite software.
2. On Tools menu, click Register button. Activation window is displayed as shown below:

   ![Activation Window]

3. If you don't have the activation key, click Get it now button in the window to go online and purchase the product.
4. Once the order is confirmed, an Activation Key gets sent to the email provided.
5. Type the Activation Key (received through email after purchasing the product) and click Activate button (Please ensure that you have an active Internet connection).
6. The software would automatically communicate with the license server to verify the entered key. If the key you entered is valid, the software will be activated successfully.
7. ‘Activation Completed Successfully’ message is displayed after the process gets completed successfully. Click OK
Updating the Software

Stellar releases periodical software updates for Stellar Repair for SQLite software. You can update the software to keep it up-to-date. These updates can add a new functionality, feature, service, or any other information that can improve the software. Update option of the application is capable of checking for latest updates. This will check for both latest minor and major versions available online. You can easily download minor version through the update wizard. However, the major version, if available, has to be purchased. While updating the software, it’s recommended to close all the running programs. Note that demo version of the software cannot be updated.

To update Stellar Repair for SQLite:

1. In Tools Menu, Click Update.

2. Stellar Phoenix Update Wizard window opens. Click Next. The wizard will search for latest updates, and if it finds any new updates, a window will pop up indicating its availability.

3. Click Next and the software will download the files from the update server. When the process is complete, the software will upgrade to the latest version.

Live Update may not happen due to following reasons:

- Internet connection failure
- Updates are not available
- Unable to download configuration files
- Unable to locate updated files or version
- Unable to locate executable file

Note: If a major version is available, you need to purchase the software in order to upgrade it.
Stellar Support

Our Technical Support professionals will give solutions for all your queries related to Stellar products.

You can either call us or go online to our support section at http://www.stellarinfo.com/support/

For price details and to place the order, click http://www.stellarinfo.com/database-recovery/sqlite-repair/buy-now.php

Chat Live with an Online technician at http://www.stellarinfo.com/

Search in our extensive Knowledge Base at http://www.stellarinfo.com/support/kb/index.php/category/sqlite-repair

Submit enquiry at http://www.stellarinfo.com/support/enquiry.php

Send e-mail to Stellar Support at support@stellarinfo.com

<table>
<thead>
<tr>
<th>Support Helpline</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Monday to Friday [ 24 Hrs. a day ]</strong></td>
</tr>
<tr>
<td></td>
</tr>
<tr>
<td>USA (Tollfree- Pre Sales Queries)</td>
</tr>
<tr>
<td>USA (Post Sales Queries)</td>
</tr>
<tr>
<td>UK (Europe)</td>
</tr>
<tr>
<td>Australia &amp; Asia Pacific</td>
</tr>
<tr>
<td>Netherlands Pre &amp; Post Sales Support</td>
</tr>
<tr>
<td>Worldwide</td>
</tr>
<tr>
<td>Email Orders</td>
</tr>
</tbody>
</table>

Select SQLite Database (DB / SQLITE) File

Stellar Repair for SQLite allows you to select SQLite database (DB / SQLITE) file from your computer for the repairing process.

To select DB / SQLITE file, follow the steps given below:

1. Open Select SQLite Database dialog box by clicking Select Database button on the Quick Access Toolbar or by choosing Select Database icon from File Menu.

2. In Select SQLite Database dialog box, click Select File.

3. Open dialog box will appear. Browse and select the desired file and then click Open.

4. Select 'Include Deleted Records' check box to repair deleted records (if found) during the repairing process.

Stellar Repair for SQLite also allows you to search for SQLite database (DB / SQLITE) files in your computer. Using Find Files option, you can search for SQLite database files in your computer's drives and subfolders. However, you can only select one drive at a time to search for SQLite database files.
To find DB / SQLITE files from your computer, follow the steps given below:

1. Open Select SQLite Database dialog box by clicking Select Database button on the Quick Access Toolbar or by choosing Select Database icon from File Menu.

2. From Look in field under Find Database section, select the drive from which you want to search for DB / SQLITE files. Also, if you want to search within subfolders, select Find in Subfolders checkbox. Click Find Files.

3. After the search is finished, a list of SQLite database files found in the selected drive is shown.

4. Select file you wish to repair from this list and click Repair button to start the repairing process.

![Stellar Repair for SQLite](image)

**Note:** Click Clear List button to clear the search result.

Using Find Files option only one file at a time can be repaired.
Include Deleted Records

Stellar Repair for SQLite provides you an option to include deleted records in SQLite database repaired file.

To include deleted records follow the steps given below:

1. Select the file by clicking on the Select Database icon from the File Menu or from the list of SQLite database files found, select the desired file to repair.

2. Select 'Include Deleted Records' check box to repair deleted records (if found) during the repairing process.

3. Click Repair to start the repairing process. Repairing of the selected file is performed by the tool.
Repair DB / SQLITE File

Stellar Repair for SQLite repairs SQLite Database (DB / SQLITE) files and allows you to save to your preferred location. You can also preview the repaired database before saving it.

To repair SQLite Database file:

1. Select the file by clicking on the Select Database icon from the File menu or from the list of SQLite Database files found, select the desired file to repair.

2. Click Repair to start the repairing process. Repairing of the selected file is performed by the tool.

3. After the completion of repairing process, a message appears indicating the successful completion of the process.
Saving process completed.
Preview and Save SQLite Database File

After you complete the repairing process successfully, Stellar Repair for SQLite shows preview of corrupted database files. The left pane displays list of items (Tables, Views and Triggers) in file in a tree like structure, upper right pane displays content of selected items and bottom pane shows the log report as shown in the figure given below:

By default, all the checkboxes are selected. To preview content of an item, click on it in the tree view in left pane.

To save the repaired SQLite database file:

- After the repairing process gets completed, click Save option from File menu or click Save button on Quick Access Toolbar.

- Save dialog box will open. Click Browse and select a destination for saving the repaired file and click OK.

- Click Save button to save the repaired SQLite database file. The file will be saved in .db or .sqlite format.
- *Saving process completed* message is displayed after the process is completed successfully. Click **OK**.
Find Specific Item In Tree

Stellar Repair for SQLite gives option to find particular item(s) in tree view. After completion of repairing process, a search bar along with the preview window appears as shown below:

To find a particular item, enter its name in Find Item text box and click Find button. If that item is present in the database, it is highlighted in tree.

To narrow down the search result, you can select Match case check box.
Save Log Report

With Stellar Repair for SQLite, you can save the Log Report to analyze the repairing process at a later stage. You can view log of the process at the bottom of the user interface. If this pane is not visible, you can enable it by selecting the Log Window checkbox in View section of File Menu.

To save log report:

- From Tools Menu, select Save Log.
- In Save As dialog box, select the location where you want to save the log report. Click Save.

To clear log report:

- From Tools Menu, select Clear Log.
FAQs

1. What does the demo version of the software do?

Demo version of the software only shows the preview of DB / SQLITE database file. To repair corrupt DB / SQLITE file, you need to purchase and register the software.

2. Why is it necessary to perform repair process on the copy of database?

Stellar Repair for SQLite will not be able to run if the database is in used by SQLite.

3. Can we repair table(s) in a DB / SQLITE file selectively?

Yes, you can repair single or multiple tables. Simply select desired table(s) in tree view and start repair process.

4. How can Stellar Repair for SQLite help us search for the location of DB / SQLITE files in the computer?

You can search for DB / SQLITE files in the computer using Find Files option of the software. For more details, please refer Select SQLite Database (DB / SQLITE) File topic of the help manual.

5. I want to locate an item in the database (DB / SQLITE) file. Is there any way I can do this using the software?

Yes, after repairing the DB / SQLITE file, the software gives you option to find items in tree view. Use Find Tree Item option from the menu bar to locate desired item in tree view.

6. How can we view process log?

You can view log of the process at the bottom of the user interface. If this pane is not visible, you can enable it by selecting the Log Window checkbox in View section of File Menu.

7. Can we save process log?

Yes, Stellar Repair for SQLite gives you option to save log report of the process.

To save log report:

- From Tools Menu, click Save Log.
- In Save As dialog box, select the location where you want to save the log report. Click Save.
Legal Notices

Copyright

**Stellar Repair for SQLite** software, accompanied user manual and documentation are copyright of Stellar Information Technology Private Limited, with all rights reserved. Under the copyright laws, this user manual cannot be reproduced in any form without the prior written permission of Stellar Information Technology Private Limited. No Patent Liability is assumed, however, with respect to the use of the information contained herein.

Copyright© Stellar Information Technology Private Limited. All rights reserved.

Disclaimer

The Information contained in this manual, including but not limited to any product specifications, is subject to change without notice.

**STELLAR INFORMATION TECHNOLOGY PRIVATE LIMITED PROVIDES NO WARRANTY WITH REGARD TO THIS MANUAL OR ANY OTHER INFORMATION CONTAINED HEREIN AND HEREBY EXPRESSLY DISCLAIMS ANY IMPLIED WARRANTIES OF MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR PURPOSE WITH REGARD TO ANY OF THE FOREGOING STELLAR INFORMATION TECHNOLOGY PRIVATE LIMITED ASSUMES NO LIABILITY FOR ANY DAMAGES INCURRED DIRECTLY OR INDIRECTLY FROM ANY TECHNICAL OR TYPOGRAPHICAL ERRORS OR OMISSIONS CONTAINED HEREIN OR FOR DISCREPANCIES BETWEEN THE PRODUCT AND THE MANUAL. IN NO EVENT SHALL STELLAR INFORMATION TECHNOLOGY PRIVATE LIMITED, BE LIABLE FOR ANY INCIDENTAL, CONSEQUENTIAL SPECIAL, OR EXEMPLARY DAMAGES, WHETHER BASED ON TORT, CONTRACT OR OTHERWISE, ARISING OUT OF OR IN CONNECTION WITH THIS MANUAL OR ANY OTHER INFORMATION CONTAINED HEREIN OR THE USE THEREOF.**

Trademarks

**Stellar Repair for SQLite®** is a registered trademark of Stellar Information Technology Private Limited.

Windows 7®, Windows 8®, Windows 8.1® and Windows 10® are registered trademarks of Microsoft® Corporation Inc.

All Trademarks Acknowledged.

All other brands and product names are trademarks or registered trademarks of their respective companies.
License Agreement

Stellar Repair for SQLite

Copyright © Stellar Information Technology Private Limited INDIA

www.stellarinfo.com

All rights reserved.

All product names mentioned herein are the trademarks of their respective owners.

This license applies to the standard-licensed version of Stellar Repair for SQLite.

Your Agreement to this License

You should carefully read the following terms and conditions before using, installing or distributing this software, unless you have a different license agreement signed by Stellar Information Technology Private Limited.

If you do not agree to all of the terms and conditions of this License then do not copy, install, distribute or use any copy of Stellar Repair for SQLite with which this License is included, you may return the complete package unused without requesting an activation key within 30 days after purchase for a full refund of your payment.

The terms and conditions of this License describe the permitted use and users of each Licensed Copy of Stellar Repair for SQLite. For purposes of this License, if you have a valid single-user license, you have the right to use a single Licensed Copy of Stellar Repair for SQLite. If you or your organization has a valid multi-user license, then you or your organization has the right to use up to a number of Licensed Copies of Stellar Repair for SQLite equal to the number of copies indicated in the documents issued by Stellar when granting the license.

Scope of License

Each Licensed Copy of Stellar Repair for SQLite may either be used by a single person or used non-simultaneously by multiple people who use the software personally installed on a single workstation. This is not a concurrent use license.

All rights of any kind in Stellar Repair for SQLite, which are not expressly granted in this license, are entirely and exclusively reserved to and by Stellar Information Technology Private Limited. You may not rent, lease, modify, translate, reverse engineer, decompile, disassemble or create derivative works based on Stellar Repair for SQLite nor permit anyone else to do so. You may not make access to Stellar Repair for SQLite available to others in connection with a service bureau, application service provider or similar business nor permit anyone else to do so.

Warranty Disclaimers and Liability Limitations

Stellar Repair for SQLite and all accompanying software, files, data and materials are distributed and provided AS IS and with no warranties of any kind, whether expressed or implied. You acknowledge that good data processing procedure dictates that any program including Stellar Repair for SQLite must be thoroughly tested with non-critical data before there is any reliance on it and you hereby assume the entire risk of all use of the copies of Stellar Repair for SQLite covered by this License. This disclaimer of warranty
constitutes an essential part of this License. In addition, in no event does Stellar authorize you or anyone else to use Stellar Repair for SQLite in applications or systems where its failure to perform can reasonably be expected to result in a significant physical injury or in loss of life. Any such use is entirely at your own risk and you agree to hold Stellar harmless from any and all claims or losses relating to such unauthorized use.

In no event shall Stellar Information Technology Private Limited or its suppliers be liable for any special, incidental, indirect, or consequential damages whatsoever (including, without limitation, damages for loss of business profits, business interruption, loss of business information, or any other pecuniary loss) arising out of the use of or inability to use the software product or the provision of or failure to provide support services, even if Stellar Information Technology Private Limited has been advised of the possibility of such damages. In any case, Stellar Information Technology Private Limited's entire liability under any provision shall be limited to the amount actually paid by you for the software product.

**General**

This License is the complete statement of the agreement between the parties on the subject matter and merges and supersedes all other or prior understandings, purchase orders, agreements and arrangements. This License shall be governed by the laws of the State of Delhi, India. Exclusive jurisdiction and venue for all matters relating to this License shall be in courts and fora located in the State of Delhi, India and you consent to such jurisdiction and venue. There are no third party beneficiaries of any promises, obligations or representations made by Stellar herein. Any waiver by Stellar of any violation of this License by you shall not constitute nor contribute to a waiver by Stellar of any other or future violation of the same provision or any other provision of this License.

Copyright© Stellar Information Technology Private Limited. All rights reserved.
About Stellar

Stellar Information Technology Private Limited is a trusted name in the field of Data Recovery and Data Protection Software for more than a decade.

We provide the widest range of Data Recovery Products. Our range includes Data Recovery Software for almost all Operating Systems and File Systems.

Product line:

Data Recovery

A widest range of data recovery software that helps you recover your valued data lost after accidental format, virus problems, software malfunction, file/directory deletion, or even sabotage! More Info >>

File Recovery

The most comprehensive range of file undelete and unerase software for Windows and MS office repair tools. More Info >>

Database Repair

A wide range of database repair software to help you repair corrupted Microsoft SQL Server database, Microsoft Access database, MySQL database, Oracle database, SharePoint Database, SQL Anywhere Server and Interbase database. More Info >>

Email Recovery

A wide range of mail recovery, mail repair and mail conversion applications for MS Outlook, MS Outlook Express and MS Exchange useful in instances of data loss due to damages and corruption of Email. More Info >>

Data Protection

A wide range of Prevent Data Loss, Data backup and Hard Drive Monitoring Applications to ensure complete data protection against hard drive crash. More Info >>

Data Sanitization

Data cleanup and file eraser utility can delete selected folders, groups of files, entire logical drives, System Traces & Internet traces. Once the data have been removed using Stellar Wipe - Data File eraser utility, it is beyond recovery limits of any Data Recovery Software or utility. More Info >>

For more information about us, please visit www.stellarinfo.com