Exchangeデータベースの復旧

Exchange DAG でパッシブデータベースのコピーをバックアップするときに発生するエラー VSS E WRITERERROR RETRYABLE を修正する方法は?

概要:

Exchange Serverのデータベース可用性グループ(DAG)では、パッシブデータベースのコピーをバックアップするときにVSS_E_WRITEERROR_RETRYABLEエラーが発生することがあります。この記事では、このエラーについて詳しく説明し、このエラーを修正するための可能な解決策を示します。また、可能な解決策が機能しない場合にデータベースを修復するために使用できるExchangeデータベース修復ツールについても言及します。

目次

Exchange Server データベース可用性グループ(DAG)内のデータベースのパッシブコピーをバックアップしようとすると、バックアップがエラーで失敗することがあります。イベントビューアを確認すると、次のようなエラーが表示されることがあります。

ライターの名前:「Microsoft Exchange Writer」。
ライターの ID:ライター ID
ライターのインスタンス IDWriterInstanceId
ステータス[1] 安定
最後のエラー繰り返し可能なエラー

注:このエラーはExchange Server 2013およびExchange Server 2016に適用されます。

バックアップを再度実行すると、同じエラーが再び発生する可能性があります。BETestツール(Microsoftの無料ツール)を使用して、サーバー上の高度なバックアップおよび復元プロセスをテストできます。このツールは以下の点をテストします:

  • 増分バックアップと差分バックアップ
  • 高度な回復オプション
  • ロールフォワード・オプション

しかし、このツールを実行しても、上記のようなエラーメッセージが表示されます。

Microsoft Exchange Writer のステータス:STABLE(0x800423f3 - VSS_E_WRITERROR_RETRYABLE)

パッシブデータベースのコピーのバックアップが開始されたサーバーで、Exchange Server Replication Service関連するアプリケーションログにID 2153のイベントが記録されていることに気づくかもしれません。

ログ名アプリケーション
ソースMSExchangeRepl
日付:<日付
イベントID2153
タスクカテゴリ:サービス
レベルエラー
キーワードクラシック
ユーザー: N/A
コンピュータ: <コンピュータ名
説明ログコピー機はサーバー<Active ServerFQDN>と通信できませんでした。データベース<Mailbox database<Local Server>>のコピーは切断状態です。通信エラーはサーバー <Active Server> との通信中にエラーが発生しました。エラーが発生しました:トランスポート接続からデータを読み取ることができません:ホストコンピュータのソフトウェアによって、既存の接続がキャンセルされました。しばらくすると、コピー機は自動的に再接続を試みます。

エラーの原因 VSS_E_WRITERROR_RETRYABLE

問題はVSSに関連しているようです。しかし、このエラーはアクティブなデータベースまたはExchange Serverの構成の問題が原因で発生する可能性もあります。ほとんどの場合、このエラーは、パッシブコピーをホストするサーバーとアクティブデータベースを持つサーバー間のリモートプロシージャコール(RPC)サービスとの通信におけるネットワークの問題または遅延が原因で発生します。RPCはExchangeサーバーのプロトコルで、Exchangeサーバー間の通信、MAPI、およびデータの転送に使用されます。これは Outlook Anywhere としても知られています。このプロトコルが動作していない場合、パッシブデータベースはアクティブデータベースからの更新を受信できません。

VSS_E_WRITERROR_RETRYABLEエラーを修正するための可能な解決策

このエラーを解決するには、以下の方法をお試しください。

解答 – 1

まず、アクティブサーバーとパッシブサーバーの間のネットワークをチェックし、ピーク時に発生するサーバー間の遅延や、2つのソース間で特定のポート/トラフィックがブロックされていないかどうかを確認する必要があります。

解答 – 2

サーバーのWindowsファイアウォールをチェックして、トラフィックが拒否されていないかどうかを確認できます。データ損失防止(DLP)、アンチウイルス、アンチマルウェアなどのサーバーのセキュリティアプリケーションをチェックして、サーバー上でプロセスがブロックされていないかどうかを確認します。

解答 – 3

Microsoft Exchange RPC Client Access サービスが実行されていることを確認する必要があります。問題がある場合は、サービスが停止されます。

Microsoft Exchange RPC Client

解答 – 4

また、Exchange Server ネットワークデバイスのタイムアウトを確認することもできます。タイムアウトが発生しないように、KeepAliveTime の値はアイドルセッションのタイムアウトよりも小さくする必要があります。これは Exchange Server レジストリの値で、タイムアウトに応じて設定および更新する必要があります。このエントリのデフォルト値は 30 秒です。タイムアウトを増やすには、各サーバーでレジストリエディタを開き、以下の操作を行います。

  • レジストリエディタを開き、以下のパスを検索します。

HKEY_LOCAL_MACHINE SOFTWARE¦Microsoft¦ExchangeServer¦v15¦Replay¦Parameter

レジストリエディタ
  • QueryLogRangeTimeoutInMsec という名前の新しい DWORD(32ビット)エントリを作成します。
QueryLogRangeTimeoutInMsec
  • 値を編集し、「Decimal」をクリックします。
Decimal
  • 値を秒単位で入力します。値を200秒に設定する場合は、200000を入力する必要があります。これは、ビジネス要件と2つのサーバー間の待ち時間によって異なります。
値を秒単位で入力します

これが完了したら、Microsoft Exchangeレプリケーションサービスを再起動して、バックアップを再試行してください。

DAGのセキュリティに関する考察

パッシブデータベースのコピーのバックアップを開始するには、Exchange レプリケーションサービスがパッシブデー タベースサーバー上でクエリーを作成し、アクティブなデータベースサーバー上のトランザクションログの範囲を取得し ます。アクティブなデータベースサーバーがビジー状態の場合、特にログファイルの数が多い場合は、クエリに予想以上の時間がかかることがあります。その後、Exchange レプリケーションサービスはアクティブなデータベースサーバーに RPC チャネルを開き、バッ クアップが実行されていることを通知します。RPC チャネルはバックアップ中も開いておく必要があります。

DAGのバックアップについては、以下の点にご注意ください:

  • バ ッ ク ア ッ プには、 ア ク テ ィ ブ デー タ ベース の コ ピーのみを使用 し て く だ さ い。パッシブデータベースコピーをバックアップすることは推奨されません。パッシブ データベースのコピーは、継続的なビジネス運用に使用する必要があります。障害が発生 し た場合にデー タ を復元す る には、 ア ク テ ィ ブ コピーのバ ッ ク ア ッ プで十分です。
  • 何らかの理由でパッシブ データベースのコピーをバックアップする必要がある場合は、アクティブ データベースのコピーが同時にバッ クアップ用に構成されていないことを確認してください。そ う で ない場合、 バ ッ ク ア ッ プは失敗 し 、 RETRYABLE エ ラ ーが発生す る 可能性があ り ます。
  • バックアップ中に、データベースを DAG 内の別の Exchange サーバーに移動しないでください。
  • ネットワーク接続がアクティブで安定していること。

DAG を使用していてデータベースのアクティブコピーとパッシブコピーを使用している場合は、Exchange Admin Centre または Exchange Management Shell を使用して各コピーの正常性とステータスを監視し、データベースコピーに関連するその他の管理タスクを実行することをお勧めします。問題が発生してデータベースが同期されないと、データの不整合によってデータが失われます。

上記の解決策でうまくいかない場合はどうすればいいのでしょうか?

上記の解決策がすべて失敗した場合は、データベースのアクティブコピーとパッシブコピー、またはExchangeサーバー自体に根本的な問題があることを意味します。  アクティブコピーが破損していて、そのコピーからデータを復元する必要がある場合はどうなりますか?データベースのパッシブコピー上のログを使用して、データベースのアクティブコピー上のログファイルからデータを復元することができます。デー タ ベース の コ ピーに ロ グ を復元す る こ と で、 デー タ ベース を過去の特定時点に復元で き ます。ログファイルを手動で操作し、Exchange Server データベースユーティリティを実行する必要があるため、このプロセスは困難です。この場合、完全なデータを復元することはできません。

アクティブコピーとパッシブコピーの両方が破損した場合はどうなりますか?そのような状況では、Stellar Repair for Exchange を使用することができます。この Exchange データ復元ソフトウェアは、あらゆるサイズの Exchange Server データベースを開くことができます。データストアを参照し、復元したデータベースを PST やその他のファイル形式にエクスポートすることができます。このシナリオでは、新しいデータベースを作成し、アクティブなExchange Serverデータベースに復旧したEDBファイルを直接エクスポートすることができます。

レビュアーについて
Expert By

Ashish

Data recovery expert

この記事は、Stellar Data Recovery社のAshish氏およびData recovery expert氏によって校閲されました。

著者について

Himanshu Shakya

Senior content writer

この記事は、Stellar Data RecoveryのSenior content writerであるHimanshu Shakya,が執筆しました。

当社のコンテンツ制作プロセスについてご興味がありますか?ぜひ 編集ガイドラインをご覧ください。

Google Trust
関連記事

>WHY STELLAR® IS GLOBAL LEADER

Why Choose Stellar?

  • 3M+

    Customers

  • 30+

    Years of Excellence

  • 100+

    R&D Engineers

  • 190+

    Countries

  • 8000+

    PARTNERS

  • 120+

    Awards Received

BitRaser With 30 Years of Excellence
信頼のテクノロジー
1993年以来のデータケアのエキスパート
×