Stellar Knowledge Base

How to Repair Files using Stellar Toolkit for File Repair?

 Modified on: September 22, 2020 |    284 views

The main interface of Stellar Toolkit for File Repair comprises four modules to repair MS Office and PDF files. These modules are:

  • Repair Document
  • Repair Spreadsheet
  • Repair PowerPoint
  • Repair PDF

Click on the desired tab to repair that file format.

Homepage of Stellar Toolkit for File Repair

                                    Figure 1 - Illustrates Homepage of the Stellar Toolkit for File Repair

Steps to Repair MS Word – .doc/.docx file

  • Click Select File to select a single corrupt Word (.doc/.docx) file that you want to repair. Alternately, click Select Folder for selecting all Word files in a single folder.

Note: Click Find file(s) to search for the Word file, if the location is not known.

Select word file

                                     Figure 2 - Illustrates Selection of single doc/.docx file or multiple files

  • Once the file is selected, click the Scan button to scan and repair the file.
  • A preview of the repaired Word file is displayed on the screen. Verify the file contents from the right pane of the preview window.

Preview of word repair

                                         Figure 3 - Preview of Repaired Word Document

Note: If you’re unable to repair a corrupt .doc file, select ‘Advance Repair’ option from the File menu for repairing the .doc files.  

  • Click the Save icon on the File menu to save the repaired file.

Select menu

                                                                     Figure 4 - File Menu

  • In Save Document dialog box that appears, do the following:
  • Select default location or a new folder to save the repaired file. 
  • Save the file in any of these formats: 'Full Document', 'Filtered Text' or 'Raw Text'.
  • Click OK.

saving word document

                                                        Figure 5 - Word Document Saving Options

The repaired file will be saved at your preferred location. 

Steps to Repair Excel – .xls/.xlsx files

  • In Select File window, click Browse to select the corrupt Excel file from the desired location. If you do not know the file location, click Search to find and select the corrupted spreadsheet.
  • Once the Excel file is selected, start repairing the file by clicking the Repair button.

Select xls/xlsx file

                              Figure 6 - Illustrates selection of one xls/xlsx file or multiple files in a folder

  • After completion of the repair process, the software displays the repaired Excel file and its recoverable data in a preview window.

preview of Excel file

                                                        Figure 7 - Preview of Excel File

  • Click on Save File icon on Home menu to save the repaired file.
  • In Save File dialog box, choose Default location or Select New Folder for saving the file.

Select destination to save repaired excel file

                                               Figure 8 - Select Destination to Save Repaired Excel File

  • Click OK to proceed with the saving process.

The repaired file gets saved at the preferred location.

Note: To recover the Engineering formulae, include ‘Analysis ToolPak’ Add-in.

 Steps to Repair PowerPoint – ppt/pptx/pptm file

  • Click Browse to select the corrupt PowerPoint file. Alternately, click on Search to search for the file, if the location is not known.

Select powerpoint presentation

                                    Figure 9 - Illustrates Selection of Single PowerPoint Presentation

  • Once the corrupt PowerPoint file is selected, click Scan for scanning and repairing the file.
  • A preview of scanned file gets displayed. Verify the file contents from the preview window.
  • Click Save on Home menu to save the repaired PPT file.
  • From the Save File dialog box, click Default location or Other location under Save As for saving the file.

Save ppt

                                                    Figure 10 - Select Location to Save PPT File

  • Click on the OK button and the repaired file is saved at preferred location.

Steps to Repair PDF file

  • From the Stellar Repair for PDF main interface window, click Add File to select a single or multiple PDF files you want to repair.

Adding corrupt pdf files

                                            Figure 11 - Illustrates adding of corrupt PDF Files

  • A screen with recently added PDF file is displayed. Select the file and click Repair to start repairing it.

Repair selected file

                                                Figure 12 - Repair the Selected PDF File

  • A screen showing the progress of the repair process appears.
  • When the ‘Repair Complete’ window pops-up, click OK.
  • Preview the repaired PDF file.
  • Click the Save Repaired Files button to save the repaired file.

save repaired file

                                                  Figure 13 - Save Repaired File

  • In Browse for Folder dialog box, select a folder for saving the file.
  • From the Saving Complete dialog box, click the hyperlink to the folder containing the repaired PDF file.

saving complete Window

                                                      Figure 14 - Saving Complete Window

  • Click OK.

 

 

User Comments


 

 

 

Related Articles