Stellar Knowledge Base

How to Resolve or Delete Outlook Duplicate Contacts

January 23, 2017     5965 views     0     0

MS Outlook is one of the most common and widely used email platforms across various organizations. It allows you to easily and efficiently send emails and manage contacts. However, there are situations like finding a duplicate name or email in the contacts folder while importing contacts in Outlook. MS Outlook has an inbuilt feature to combat such situation by either allowing you to add a duplicate contact as a new contact or update the existing contact with the new contact. Else, you can always delete duplicate contacts, which are not relevant.

The Options available to avoid duplication

1.    In the Duplicate Contact Detected dialog box, add duplicate contact as a new contact in the contacts folder.
2.    Display the contacts as Electronic Business Cards option.
3.    Updating the existing contact name with new information. Outlook compares all the fields and updates the contact in case of conflicting data. Outlook always stores a duplicate entry of the original contact in the Deleted Items folder. This helps in reverting back to the information in the original contact.

4.    Delete duplicate contacts in case all the information is same. This is a manual process. However, it is recommended to follow the following steps in case you are working with Outlook 2007.

i.    Go to Contacts and select the folder that has duplicate contacts.
ii.    Select the Phone List in the navigation pane to see duplicate contacts.
iii.    Sort the list as per the ease to group the duplicates together.
iv.    On the View Menu, go to Current View->Customize Current View.
v.    Click Fields->Available fields list, select Modified->click Add.
vi.    Click Move until you get an ordered list.
vii.    Click OK twice.
viii.    In the Contacts list select duplicate contacts by using the CTRL key.
ix.    Press Delete.

Note: While importing Contacts, do not import duplicates. However, you can always turn off the Duplicate Detection feature while importing contacts. This feature slows down the transfer rate. In case of huge number of contacts, you may not use the Duplication Detection feature to speed up the process. You can easily turn off this feature by following steps:
             
         1. Click Options on the Tools menu.
         2. Click Contact Options, and uncheck the Check for duplicate contacts check box.
 
While using Outlook we may need to import PST files multiple times. This might result in unnecessary accumulation of multiple copies of the same mail. This would eventually increase the PST size, and might get corrupted if the size exceeds beyond a certain limit. In such a situation, it is always recommended to use a professional tool. Stellar Outlook Duplicate Remover is an apt solution for removing duplicate entries of mail items from MS Outlook. The software comes with various scan criteria, which helps us to easily search for duplicate mails. The software follows a simple duplicate email removal process as mentioned below.

1.    Click the add-in icon of the software from the toolbar to launch the Stellar Outlook Duplicate Remover.
2.     The 'Folder List' window displays the list of mail folders. You can select the desired folder to search for the duplicate emails.
3.    Click 'Next'.
4.    Choose the 'Time Span', 'Comparison Criteria' and 'Action' from the drop down boxes available on the Window.
5.    Click 'Run Process' to begin the operation.
6.    The ongoing process is shown by a progress bar at the bottom of the interface. The Software simultaneously displays the detected duplicate emails as the scan goes on.
7.    A process completed mailbox is displayed once the process gets completed.
8.    Click 'OK'.
9.    The summary of the entire process is shown in a 'Log report' generated at the end. You can click 'Save Log' to store the report for any future reference.

 

User Comments


 

 

 

Related Articles